#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:<Person[\d\s]+|>)"
Local $sString = "<Person 1234567 Tom Brady>" & @CRLF & _
"<Person 456789012 Mary Ann Thomas>" & @CRLF & _
"<Person 92145 John Smith>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)