import re
regex = re.compile(r"(?:<Person[\d\s]+|>)", flags=re.MULTILINE)
test_str = ("<Person 1234567 Tom Brady>\n"
"<Person 456789012 Mary Ann Thomas>\n"
"<Person 92145 John Smith>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)