re = /(?:<Person[\d\s]+|>)/m
str = '<Person 1234567 Tom Brady>
<Person 456789012 Mary Ann Thomas>
<Person 92145 John Smith>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result