#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[\r\n]{2}((?:[\s\S](?!\n\n))+)$"
Local $sString = "Машина" & @CRLF & _
"текст текст текст" & @CRLF & _
"" & @CRLF & _
"Кот" & @CRLF & _
"текст" & @CRLF & _
"динамический текст еще" & @CRLF & _
"" & @CRLF & _
"Кот" & @CRLF & _
"текст " & @CRLF & _
"еще динамический текст"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")