using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\r\n]{2}((?:[\s\S](?!\n\n))+)$";
string input = @"Машина
текст текст текст
Кот
текст
динамический текст еще
Кот
текст
еще динамический текст";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}