$re = '/[\r\n]{2}((?:[\s\S](?!\n\n))+)$/i';
$str = 'Машина
текст текст текст
Кот
текст
динамический текст еще
Кот
текст
еще динамический текст';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);