import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\r\\n]{2}((?:[\\s\\S](?!\\n\\n))+)$";
final String string = "Машина\n"
+ "текст текст текст\n\n"
+ "Кот\n"
+ "текст\n"
+ "динамический текст еще\n\n"
+ "Кот\n"
+ "текст \n"
+ "еще динамический текст";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}