const regex = /[\r\n]{2}((?:[\s\S](?!\n\n))+)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\r\\n]{2}((?:[\\s\\S](?!\\n\\n))+)$', 'i')
const str = `Машина
текст текст текст
Кот
текст
динамичес кий текст еще
Кот
текст
еще динамический текст`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}