import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<id>[^=]+)=(?:<Picture id=\"(?<picture>[^\"]*)\"\\/?>)?(?<stuff><[^>]*>)?(?<description>.*)";
final String string = "STR_ABL_DAMUP_WIND_EXPLAIN=<Picture id=\"ICN_PRM_007\"/>Wind attack power +{Perc}%\n"
+ "STR_ARENA_ENTRY_INFOMATION_PAGE_05=<__>The first time you clear the challenge, you will receive a<__><Color id=\"Yellow\">reward</Color>, so give it your all!\n"
+ "STR_CHAT_VIEWER_TRADE_SPIRITS=You can unlock this chat for {TradeRate} katz spirits.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}