use strict;
my $str = 'STR_ABL_DAMUP_WIND_EXPLAIN=<Picture id="ICN_PRM_007"/>Wind attack power +{Perc}%
STR_ARENA_ENTRY_INFOMATION_PAGE_05=<__>The first time you clear the challenge, you will receive a<__><Color id="Yellow">reward</Color>, so give it your all!
STR_CHAT_VIEWER_TRADE_SPIRITS=You can unlock this chat for {TradeRate} katz spirits.
';
my $regex = qr/^(?<id>[^=]+)=(?:<Picture id="(?<picture>[^"]*)"\/?>)?(?<stuff><[^>]*>)?(?<description>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}