// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?<id>[^=]+)=(?:<Picture id="(?<picture>[^"]*)"\/?>)?(?<stuff><[^>]*>)?(?<description>.*)"#).unwrap();
let string = "STR_ABL_DAMUP_WIND_EXPLAIN=<Picture id=\"ICN_PRM_007\"/>Wind attack power +{Perc}%
STR_ARENA_ENTRY_INFOMATION_PAGE_05=<__>The first time you clear the challenge, you will receive a<__><Color id=\"Yellow\">reward</Color>, so give it your all!
STR_CHAT_VIEWER_TRADE_SPIRITS=You can unlock this chat for {TradeRate} katz spirits.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}