# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<id>[^=]+)=(?:<Picture id=\"(?<picture>[^\"]*)\"\/?>)?(?<stuff><[^>]*>)?(?<description>.*)"
test_str = ("STR_ABL_DAMUP_WIND_EXPLAIN=<Picture id=\"ICN_PRM_007\"/>Wind attack power +{Perc}%\n"
"STR_ARENA_ENTRY_INFOMATION_PAGE_05=<__>The first time you clear the challenge, you will receive a<__><Color id=\"Yellow\">reward</Color>, so give it your all!\n"
"STR_CHAT_VIEWER_TRADE_SPIRITS=You can unlock this chat for {TradeRate} katz spirits.\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.