using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<(\w+)(?:\s[^<>]+)?\>(?!(?:.|\n)*\<\/\1\>)";
string input = @"<a href=""a_url"" class=""url"" target=""_blank"">
<img ng-src="" {{getImageUrl('homeHelp64.jpg')}}"" alt=""?"" width=""16"" height=""16"">
<alt>
</aldt> // invalid
</imgv> // invalid
</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}