const regex = /\<(\w+)(?:\s[^<>]+)?\>(?!(?:.|\n)*\<\/\1\>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<(\\w+)(?:\\s[^<>]+)?\\>(?!(?:.|\\n)*\\<\\\/\\1\\>)', 'g')
const str = `<a href="a_url" class="url" target="_blank">
<img ng-src=" {{getImageUrl('homeHelp64.jpg')}}" alt="?" width="16" height="16">
<alt>
</aldt> // invalid
</imgv> // invalid
</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}