re = /\<(\w+)(?:\s[^<>]+)?\>(?!(?:.|\n)*\<\/\1\>)/
str = '<a href="a_url" class="url" target="_blank">
<img ng-src=" {{getImageUrl(\'homeHelp64.jpg\')}}" alt="?" width="16" height="16">
<alt>
</aldt> // invalid
</imgv> // invalid
</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end