import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<(\\w+)(?:\\s[^<>]+)?\\>(?!(?:.|\\n)*\\<\\/\\1\\>)";
final String string = "<a href=\"a_url\" class=\"url\" target=\"_blank\">\n"
+ " <img ng-src=\" {{getImageUrl('homeHelp64.jpg')}}\" alt=\"?\" width=\"16\" height=\"16\">\n"
+ " <alt>\n"
+ " </aldt> // invalid\n"
+ " </imgv> // invalid\n"
+ "</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}