#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([A-D]:[\w ]*correct)"
Local $sString = "1: How old am I?" & @CRLF & _
"A: 8 days" & @CRLF & _
"B: 75" & @CRLF & _
"C: 100" & @CRLF & _
"D: 99correct" & @CRLF & _
"xxxxxxxxxxxx" & @CRLF & _
"2: What is your favorite color?" & @CRLF & _
"A: blue" & @CRLF & _
"B: greencorrect" & @CRLF & _
"C: red" & @CRLF & _
"D: blue" & @CRLF & _
"xxxxxxxxxxxx"
Local $sSubst = "xxxxxxxxxxxx \1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)