import re
regex = re.compile(r"([A-D]:[\w ]*correct)", flags=re.MULTILINE)
test_str = ("1: How old am I?\n"
"A: 8 days\n"
"B: 75\n"
"C: 100\n"
"D: 99correct\n"
"xxxxxxxxxxxx\n"
"2: What is your favorite color?\n"
"A: blue\n"
"B: greencorrect\n"
"C: red\n"
"D: blue\n"
"xxxxxxxxxxxx")
subst = "xxxxxxxxxxxx \\1"
result = regex.sub(subst, test_str)
if result:
print(result)