$re = '/([A-D]:[\w ]*correct)/m';
$str = '1: How old am I?
A: 8 days
B: 75
C: 100
D: 99correct
xxxxxxxxxxxx
2: What is your favorite color?
A: blue
B: greencorrect
C: red
D: blue
xxxxxxxxxxxx';
$subst = "xxxxxxxxxxxx \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;