package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-D]:[\w ]*correct)`)
var str = `1: How old am I?
A: 8 days
B: 75
C: 100
D: 99correct
xxxxxxxxxxxx
2: What is your favorite color?
A: blue
B: greencorrect
C: red
D: blue
xxxxxxxxxxxx`
var substitution = "xxxxxxxxxxxx \1"
fmt.Println(re.ReplaceAllString(str, substitution))
}