using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""ip\"":\""([^\""]+)\"".+\""action\"":\""phpExecution\"".+";
string input = @"<200> Nov 16 14:36:10 phpExecution INFO: Php Execution {""ip"":""33.333.333.33"",""workspace"":""gasqazvin"",""timeZone"":""2019-11-16 14:11:10"",""usrUid"":"",""action"":""phpExecution"",""filename"":""/var/www/html/pm/shared/sites/work/public/1244635345345/23425452.php"",""url"":""/syswork/fa/modern/1244635345345/23425452.php?""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}