// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"ip\":\"([^\"]+)\".+\"action\":\"phpExecution\".+"#).unwrap();
let string = "<200> Nov 16 14:36:10 phpExecution INFO: Php Execution {\"ip\":\"33.333.333.33\",\"workspace\":\"gasqazvin\",\"timeZone\":\"2019-11-16 14:11:10\",\"usrUid\":\"\",\"action\":\"phpExecution\",\"filename\":\"/var/www/html/pm/shared/sites/work/public/1244635345345/23425452.php\",\"url\":\"/syswork/fa/modern/1244635345345/23425452.php?\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}