re = /\"ip\":\"([^\"]+)\".+\"action\":\"phpExecution\".+/m
str = '<200> Nov 16 14:36:10 phpExecution INFO: Php Execution {"ip":"33.333.333.33","workspace":"gasqazvin","timeZone":"2019-11-16 14:11:10","usrUid":"","action":"phpExecution","filename":"/var/www/html/pm/shared/sites/work/public/1244635345345/23425452.php","url":"/syswork/fa/modern/1244635345345/23425452.php?"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end