import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"ip\\\":\\\"([^\\\"]+)\\\".+\\\"action\\\":\\\"phpExecution\\\".+";
final String string = "<200> Nov 16 14:36:10 phpExecution INFO: Php Execution {\"ip\":\"33.333.333.33\",\"workspace\":\"gasqazvin\",\"timeZone\":\"2019-11-16 14:11:10\",\"usrUid\":\"\",\"action\":\"phpExecution\",\"filename\":\"/var/www/html/pm/shared/sites/work/public/1244635345345/23425452.php\",\"url\":\"/syswork/fa/modern/1244635345345/23425452.php?\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}