# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"ip\":\"([^\"]+)\".+\"action\":\"phpExecution\".+"
test_str = "<200> Nov 16 14:36:10 phpExecution INFO: Php Execution {\"ip\":\"33.333.333.33\",\"workspace\":\"gasqazvin\",\"timeZone\":\"2019-11-16 14:11:10\",\"usrUid\":\"\",\"action\":\"phpExecution\",\"filename\":\"/var/www/html/pm/shared/sites/work/public/1244635345345/23425452.php\",\"url\":\"/syswork/fa/modern/1244635345345/23425452.php?\"}"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.