using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h1>(.*?)<\/h1>((?!<h1>))*";
string substitution = @"$1 $2";
string input = @"<h1>Foo</h1><h2>Bar</h2><h1>Baz</h1><h3>Test</h3><h1>ghj</h1>zuio";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}