re = /<h1>(.*?)<\/h1>((?!<h1>))*/m
str = '<h1>Foo</h1><h2>Bar</h2><h1>Baz</h1><h3>Test</h3><h1>ghj</h1>zuio'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result