import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h1>(.*?)<\\/h1>((?!<h1>))*";
final String string = "<h1>Foo</h1><h2>Bar</h2><h1>Baz</h1><h3>Test</h3><h1>ghj</h1>zuio";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}