using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/?\h*(\w+)(?=(?:\h*/\h*\w+)+metastase\b)(?:\h*/)?";
string substitution = @"$1metastase ";
string input = @"lever/botmetastase
kidney/lever/botmetastase
pancreas/kidney/lever/botmetastase
lever / botmetastase
kidney /lever/ botmetastase
pancreas /kidney / lever/ botmetastase
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}