re = /\/?\h*(\w+)(?=(?:\h*\/\h*\w+)+metastase\b)(?:\h*\/)?/m
str = 'lever/botmetastase
kidney/lever/botmetastase
pancreas/kidney/lever/botmetastase
lever / botmetastase
kidney /lever/ botmetastase
pancreas /kidney / lever/ botmetastase
'
subst = '$1metastase '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result