use strict;
my $str = 'lever/botmetastase
kidney/lever/botmetastase
pancreas/kidney/lever/botmetastase
lever / botmetastase
kidney /lever/ botmetastase
pancreas /kidney / lever/ botmetastase
';
my $regex = qr@/?\h*(\w+)(?=(?:\h*/\h*\w+)+metastase\b)(?:\h*/)?@mp;
my $subst = '$1metastase ';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";