using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\{\{if gender ==) (?:""Male""|""Female""|""Both""|""Unknown"")\}\}$";
string input = @"{{if gender == ""Male""}}
{{if gender == ""Female""}}
{{if gender == ""Both""}}
{{if gender == ""Unknown""}}";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}