import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\{\\{if gender ==) (?:\"Male\"|\"Female\"|\"Both\"|\"Unknown\")\\}\\}$";
final String string = "{{if gender == \"Male\"}}\n"
+ "{{if gender == \"Female\"}}\n"
+ "{{if gender == \"Both\"}}\n"
+ "{{if gender == \"Unknown\"}}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}