re = /^(?:\{\{if gender ==) (?:"Male"|"Female"|"Both"|"Unknown")\}\}$/im
str = '{{if gender == "Male"}}
{{if gender == "Female"}}
{{if gender == "Both"}}
{{if gender == "Unknown"}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end