using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https{1}:\/\/(?:\$INSTANCE\$)(?:\/\w+){0,255}(?:\?\w+=\w+){0,1}(?:\&\w+=\w+){0,255}";
string input = @"https://$INSTANCE$/lalal/hth?fgtr=gbd&hhh=ggg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}