import re
regex = re.compile(r"https{1}:\/\/(?:\$INSTANCE\$)(?:\/\w+){0,255}(?:\?\w+=\w+){0,1}(?:\&\w+=\w+){0,255}", flags=re.MULTILINE)
test_str = "https://$INSTANCE$/lalal/hth?fgtr=gbd&hhh=ggg"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")