import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https{1}:\\/\\/(?:\\$INSTANCE\\$)(?:\\/\\w+){0,255}(?:\\?\\w+=\\w+){0,1}(?:\\&\\w+=\\w+){0,255}";
final String string = "https://$INSTANCE$/lalal/hth?fgtr=gbd&hhh=ggg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}