const regex = /https{1}:\/\/(?:\$INSTANCE\$)(?:\/\w+){0,255}(?:\?\w+=\w+){0,1}(?:\&\w+=\w+){0,255}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https{1}:\\\/\\\/(?:\\$INSTANCE\\$)(?:\\\/\\w+){0,255}(?:\\?\\w+=\\w+){0,1}(?:\\&\\w+=\\w+){0,255}', 'gm')
const str = `https://\$INSTANCE\$/lalal/hth?fgtr=gbd&hhh=ggg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}