re = /https{1}:\/\/(?:\$INSTANCE\$)(?:\/\w+){0,255}(?:\?\w+=\w+){0,1}(?:\&\w+=\w+){0,255}/m
str = 'https://$INSTANCE$/lalal/hth?fgtr=gbd&hhh=ggg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end