import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n?^SPLIT$\\n?";
final String string = "Hello there,\n"
+ "SPLIT\n"
+ "how are you?\n\n"
+ "Hello there, SPLIT how are you?\n\n"
+ "Hello there,\n"
+ "SPLIT\n\n"
+ "Hello there,\n"
+ "SPLIT how are you?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}