import re
regex = re.compile(r"\n?^SPLIT$\n?", flags=re.MULTILINE)
test_str = ("Hello there,\n"
"SPLIT\n"
"how are you?\n\n"
"Hello there, SPLIT how are you?\n\n"
"Hello there,\n"
"SPLIT\n\n"
"Hello there,\n"
"SPLIT how are you?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")