re = /\n?^SPLIT$\n?/m
str = 'Hello there,
SPLIT
how are you?
Hello there, SPLIT how are you?
Hello there,
SPLIT
Hello there,
SPLIT how are you?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end