#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+(?=\.[^.]+$)"
Local $sString = "<<< VIDEOS >>>" & @CRLF & _
"01. Uno.mkv" & @CRLF & _
"02. Mijo.mkv" & @CRLF & _
"03. Nacho.mkv" & @CRLF & _
"04. Hero.mkv" & @CRLF & _
"05. Alpine Shepherd Boy.mkv" & @CRLF & _
"06. Five-O.mkv" & @CRLF & _
"07. Bingo.mkv" & @CRLF & _
"08. RICO.mkv" & @CRLF & _
"09. Pimento.mkv" & @CRLF & _
"10. Marco.mkv" & @CRLF & _
"" & @CRLF & _
"<<< SUBTITLES >>>" & @CRLF & _
"Better.Call.Saul.S01E01.720p.BluRay.X264-REWARD.srt" & @CRLF & _
"Better.Call.Saul.S01E02.720p.BluRay.X264-REWARD.srt" & @CRLF & _
"Better.Call.Saul.S01E03.720p.BluRay.X264-REWARD.srt" & @CRLF & _
"Better.Call.Saul.S01E04.720p.BluRay.X264-REWARD.srt" & @CRLF & _
"Better.Call.Saul.S01E05.720p.BluRay.X264-REWARD.srt" & @CRLF & _
"Better.Call.Saul.S01E06.720p.BluRay.X264-REWARD.srt" & @CRLF & _
"Better.Call.Saul.S01E07.720p.BluRay.X264-REWARD.srt" & @CRLF & _
"Better.Call.Saul.S01E08.720p.BluRay.X264-REWARD.srt" & @CRLF & _
"Better.Call.Saul.S01E09.720p.BluRay.X264-REWARD.srt" & @CRLF & _
"Better.Call.Saul.S01E10.720p.BluRay.X264-REWARD.srt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")