import re
regex = re.compile(r".+(?=\.[^.]+$)", flags=re.MULTILINE)
test_str = ("<<< VIDEOS >>>\n"
"01. Uno.mkv\n"
"02. Mijo.mkv\n"
"03. Nacho.mkv\n"
"04. Hero.mkv\n"
"05. Alpine Shepherd Boy.mkv\n"
"06. Five-O.mkv\n"
"07. Bingo.mkv\n"
"08. RICO.mkv\n"
"09. Pimento.mkv\n"
"10. Marco.mkv\n\n"
"<<< SUBTITLES >>>\n"
"Better.Call.Saul.S01E01.720p.BluRay.X264-REWARD.srt\n"
"Better.Call.Saul.S01E02.720p.BluRay.X264-REWARD.srt\n"
"Better.Call.Saul.S01E03.720p.BluRay.X264-REWARD.srt\n"
"Better.Call.Saul.S01E04.720p.BluRay.X264-REWARD.srt\n"
"Better.Call.Saul.S01E05.720p.BluRay.X264-REWARD.srt\n"
"Better.Call.Saul.S01E06.720p.BluRay.X264-REWARD.srt\n"
"Better.Call.Saul.S01E07.720p.BluRay.X264-REWARD.srt\n"
"Better.Call.Saul.S01E08.720p.BluRay.X264-REWARD.srt\n"
"Better.Call.Saul.S01E09.720p.BluRay.X264-REWARD.srt\n"
"Better.Call.Saul.S01E10.720p.BluRay.X264-REWARD.srt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")