$re = '/.+(?=\.[^.]+$)/m';
$str = '<<< VIDEOS >>>
01. Uno.mkv
02. Mijo.mkv
03. Nacho.mkv
04. Hero.mkv
05. Alpine Shepherd Boy.mkv
06. Five-O.mkv
07. Bingo.mkv
08. RICO.mkv
09. Pimento.mkv
10. Marco.mkv
<<< SUBTITLES >>>
Better.Call.Saul.S01E01.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E02.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E03.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E04.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E05.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E06.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E07.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E08.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E09.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E10.720p.BluRay.X264-REWARD.srt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);