use strict;
my $str = '<<< VIDEOS >>>
01. Uno.mkv
02. Mijo.mkv
03. Nacho.mkv
04. Hero.mkv
05. Alpine Shepherd Boy.mkv
06. Five-O.mkv
07. Bingo.mkv
08. RICO.mkv
09. Pimento.mkv
10. Marco.mkv
<<< SUBTITLES >>>
Better.Call.Saul.S01E01.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E02.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E03.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E04.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E05.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E06.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E07.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E08.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E09.720p.BluRay.X264-REWARD.srt
Better.Call.Saul.S01E10.720p.BluRay.X264-REWARD.srt';
my $regex = qr/.+(?=\.[^.]+$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}