import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+(?=\\.[^.]+$)";
final String string = "<<< VIDEOS >>>\n"
+ "01. Uno.mkv\n"
+ "02. Mijo.mkv\n"
+ "03. Nacho.mkv\n"
+ "04. Hero.mkv\n"
+ "05. Alpine Shepherd Boy.mkv\n"
+ "06. Five-O.mkv\n"
+ "07. Bingo.mkv\n"
+ "08. RICO.mkv\n"
+ "09. Pimento.mkv\n"
+ "10. Marco.mkv\n\n"
+ "<<< SUBTITLES >>>\n"
+ "Better.Call.Saul.S01E01.720p.BluRay.X264-REWARD.srt\n"
+ "Better.Call.Saul.S01E02.720p.BluRay.X264-REWARD.srt\n"
+ "Better.Call.Saul.S01E03.720p.BluRay.X264-REWARD.srt\n"
+ "Better.Call.Saul.S01E04.720p.BluRay.X264-REWARD.srt\n"
+ "Better.Call.Saul.S01E05.720p.BluRay.X264-REWARD.srt\n"
+ "Better.Call.Saul.S01E06.720p.BluRay.X264-REWARD.srt\n"
+ "Better.Call.Saul.S01E07.720p.BluRay.X264-REWARD.srt\n"
+ "Better.Call.Saul.S01E08.720p.BluRay.X264-REWARD.srt\n"
+ "Better.Call.Saul.S01E09.720p.BluRay.X264-REWARD.srt\n"
+ "Better.Call.Saul.S01E10.720p.BluRay.X264-REWARD.srt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}