#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=CURRENT)(.|\n)*(?=\*Attention: Product Manager)"
Local $sString = "*Before and after:" & @CRLF & _
"" & @CRLF & _
"CURRENT" & @CRLF & _
"" & @CRLF & _
"-----------------------------------------------------------------------------" & @CRLF & _
"Product ID : J73820" & @CRLF & _
"Quantity : 75" & @CRLF & _
"Title : Jeans" & @CRLF & _
"Brand: XXXX" & @CRLF & _
"-----------------------------------------------------------------------------" & @CRLF & _
"NEXT ACTION" & @CRLF & _
"Increase stock" & @CRLF & _
"" & @CRLF & _
"TO BE" & @CRLF & _
"" & @CRLF & _
"-----------------------------------------------------------------------------" & @CRLF & _
"Product ID : J73820" & @CRLF & _
"Quantity : 100" & @CRLF & _
"Title : Jeans" & @CRLF & _
"Brand: XXXX" & @CRLF & _
"-----------------------------------------------------------------------------" & @CRLF & _
"NEXT ACTION" & @CRLF & _
"Add 25 unit" & @CRLF & _
"" & @CRLF & _
"*Attention: Product Manager" & @CRLF & _
"*Classification: N/A" & @CRLF & _
"" & @CRLF & _
"C) For urgent product"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")