const regex = /(?<=CURRENT)(.|\n)*(?=\*Attention: Product Manager)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=CURRENT)(.|\\n)*(?=\\*Attention: Product Manager)', 'gm')
const str = `*Before and after:
CURRENT
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 75
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Increase stock
TO BE
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 100
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Add 25 unit
*Attention: Product Manager
*Classification: N/A
C) For urgent product`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}