re = /(?<=CURRENT)(.|\n)*(?=\*Attention: Product Manager)/m
str = '*Before and after:
CURRENT
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 75
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Increase stock
TO BE
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 100
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Add 25 unit
*Attention: Product Manager
*Classification: N/A
C) For urgent product'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end